CalaisTurbo New Tags
User Name: Password:

Go Back   calaisturbo.com.au > calaisturbo.com.au > VL Non-Turbo Discussion
G-Cylinder

Reply

 

Thread Tools
Old 09-11-12, 23:53   #1
seymour88
Player
 
Join Date: 09-11-12
Location: QLD, helensvale
Car:
Trader Rating: (0)
vl

hello i have just bought a vl and it runs really ruff i have changed the fuel pump today and runs a lot better but sill is a little doggy when i give it a good rev what should i fix next the fuel regulator or the injectors????????????
seymour88 is offline   Reply With Quote
Old 10-11-12, 00:05   #2
boosted_wagon
loves to drink Alcohol
 
boosted_wagon's Avatar
 
Join Date: 23-02-04
Location: QLD, mount warren park
Car: factory vl berlina turbo wagon new 2 tone paint, ford territory titanium
Trader Rating: (48)
Send a message via MSN to boosted_wagon
Try checking for a vaccume leak then try changing the spark plugs rotor button dizzy cap and leads for starters, who knows when the last time they wet changed was.... Start small mate then try air flow meter, oxy sensor, throttle position sensor,
boosted_wagon is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 23:01.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger